eobdtool

eobdtool
Welcome to eobdtool

2015-10-06

Scania SDP3 VCI2 V2.23 firmware update error (fixed)

Scania SDP3 VCI 2 firmware update errors occurred when updating VCI 2 Firmware mistakenly. Here is the proper solution provided.
Problem:
After install Scania SDP3 V2.23 software on Win 7 32-bit operating system, the software
prompts:
“The software in VCI is not the latest version. Click OK to install new VCI software”
Scania-VCI2-SDP3-error-1
After press on OK button and move on, the system again displayed another error message: “An error occurred when updating VCI”
Scania-VCI2-SDP3-error-2
Scania-VCI2-SDP3-error-3 
“Updating VCI2 firmware with error code 1”
Possible reason:
Scania SDP3 software is not well/completely installed.
Solution:
Never update Scania VCI2 SDP3 software & firmware. For software update, you need to purchase latest software CD.
If you have above errors, then follow the instruction below:
First of all, download SDP3 software 2.20, 2.21 and 2.23 files here
All three folder contain SAMPi.dll and SMAPi.old.dll files
Scania-SDP3-VCI2-Update-error-fix-1
Do not copy SAMPi.dll file. First run SDP3 2.20 software, if it prompts to update VCI2 firmware, then copy to replace SAMPi.dll file.
If you have replaced the SAMPi.dll file, but the error still there, then un-install SDP3 software on another Win 7 laptop.